Compatibility Versions of Illustrator and CorelDraw

Graphtec’s proprietary software that allows users to work directly from Adobe® Illustrator and /or CorelDraw® with Graphtec Cutting Plotters.

Windows Requirements Windows 98SE/ME/2000/XP/Pro/Vista/7/8 with minimum hardware requirement of Pentium III and 600Mhz, 256MB RAM. Cutting Master 2 V1.87 works with Adobe® Illustrator versions 8 – CS6; CorelDraw® 10 – X6*

*Cutting Master 2 Compatibility with CorelDraw
CorelDraw Graphics Suite X6 (includes Visual Basic)
CorelDraw Premium Suite X6 (includes Visual Basic)

Cannot use Cutting Master with CorelDraw Download (Home) version or Education version since they do not include Visual Basic. Users with these two versions have to contact Corel and upgrade to full versions.

Macintosh RequirementsPowerPC G4/G5 with OSX 10.28 or newer. Macintosh with Intel Core Mac OSX 10.4 – 10.8
Cutting Master 2 works with Adobe® Illustrator versions 10 – CS6

Attention CorelDraw X5 users Installing an update for Corel Draw X6 called "Service Pack 2" will force Cutting Master to stop working. You will receive an error message "Running Corel Draw Not Found" and cutting output will be disabled.

If you already have this issue: Uninstall the service pack 2 of Corel Draw X6 and uninstall Cutting Master 2. DOWNLOAD NEW CUTTING MASTER 2 Version 1.90, and then reinstall the CDX6 and CM2.

WARNING
CUTTING MASTER WILL NOT INSTALL INTO PIRATED OR PATCHED COPIES OF ADOBE® ILLUSTRATOR OR COREL DRAW®

DOWNLOAD LATEST VERSION OF CUTTING MASTER FOR YOUR SPECIFIC MACHINE

Back to Cutting Master 2 FAQs

Back to Software Video FAQs